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Foreword
After the success I received by writing my first Book “Finite Element Analysis using Open Source Software”, I 
received many email communications congratulating me and telling me how easy it was to use my book.  Readers 
had found an easy to use, easy to read and easy to follow documentation for Open Source Software that can be 
used for Finite Element analysis.  Some said that they completed the entire book with the exercise within one single 
weekend and I doubt if they had taken any sleep in between.  

The users of my book were fresh graduates from the university who knew the fundamentals and had been using 
proprietor software in their university and now as they were out of university, they wanted to use something 
that doesn’t hurt their hip pocket.  Others were seasoned professionals who knew other proprietary software but 
wanted to know how to perform FEA using Open Source Software.

This book starts with updated examples in version 11.x for Code_Aster from previous book.  It then goes on and 
adds on advanced analysis.

This book is written for

Those who have a passion for learning Open Source software, particularly CAD and FEA software.  This book is 
written for those who are new to software like Salome and Code_Aster.  

If you are having trouble understanding where to start with Salome and Code_Aster, this book is written for you.  
If you are having troubles understanding the computer translated Code_Aster User Documents (which are rich in 
information), this book is written for you.  If you want easy reference to 75% of FEA problems that are encountered 
by engineers in day to day life and want to do that by Open Source Software, this book is written for you.

This book is for those who don’t want to waste their time in finding tutorials online and trying to make logical and 
sequential sense.  This book starts with a very basic introduction of what to do to perform FE Analysis, and then, 
with each new Chapter, it introduces new concepts in an easy to understand format.  If you want to learn how to 
do FE Analysis with Open Source software in a week’s time, than this book is for you.

This book is not written for

If you are advanced user of Salome and Code_Aster and after reading the Table of Content you can say to yourself 
that “the information covered in this book is something that I already know”, this book is not for you.

This book is also not written for someone who does not know what Finite Element Analysis is.  FE Analysis, as a 
fundamental, should be known to the user of this book.

If you are a beginner, it is advised that you purchase our first book “Finite Element Analysis with Open Source 
Software” where you will be able to gain more insights into the fundamental analysis that can be done with Salome-
Meca and Code_Aster.

Once you are familiar with those concepts, this book will be easy to follow.  Some of the chapters in this book rely 
on the information given in the first book.  Though it is not necessary, it is recommended to complete the first 
book before you start with this one.
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What software would you need to follow through

Operating System used:

1.	 Ubuntu 12.04

Software used for this book are

1.	 Salome-Meca version 2013.2

2.	 Code Aster version 11.3

3.	 Efficient version 0.1.1

All of the above software (except latest version of Efficient) are available in CAELinux 2013 DVD so if you have 
installed it, don’t worry about any more installations.  If you want to use latest software, install the above versions 
or latest versions of these software on your computer.  Please note that if you install a software that is of higher 
version than that mentioned above, the screenshots may differ, but the fundamental concepts remain the same.
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What are the steps in Finite Element Analysis
This book does not teach you what Finite Element Analysis is.  You are nearly ready if you are familiar with the 
general form of Hook’s law which states that “For small deformations of the object, the amount of deformation / 
displacement (Dx) is directly proportional to the deforming force or load (F)”.  The constant of proportionality in 
the above equation is the stiffness (k) of the object. 

Generally the stiffness of the object is known due to the fact that we would have its shape and material properties 
as a given.  If not, Either we would be optimising its shape by finding stresses generated in the object due to applied 
loads (e.g. objective of the study can be “optimise web thickness of gussets or optimise thickness of a pressure 
vessel Nozzle saddle”), or we would be checking which material is most suitable for the given object (e.g. objective 
of the study can be “Can Aluminium alloy be used to reduce the weight of the object?”).  So stiffness “k” would be 
fixed for the given analysis based on shape and material selected.

The next step is boundary conditions.  Any given object has to be sufficiently supported in the real world and FEA 
will emulate these supports, either there is a fixed support (e.g. bolted or welded joint), sliding support (e.g. shaft 
in hub or pipe shoe on structural steel).  By applying these boundary conditions of supports, we are providing / 
fixing values of displacement.  Then there would be forces applied to the object, either by gravity (self-weight) or 
by pressure applied on a surface or force applied on the object.  By adding these boundary conditions of loads, we 
are providing / fixing values of force / load. 

After all of the above is given to Code Aster (FE analysis software of choice for this book), it tries to solve the equation 
which will be in matrix form with the given input values of displacement and forces and obtain displacement for 
the entire object.  These displacements (Strains) are converted to Stresses (Stress = Strain multiplied by Young’s 
Modulus of the material, for elastic case) and are displayed as a coloured model or exported as a table. 

Figure on the next page shows general steps to perform FEA.
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In the coming chapters of this book, we will be using above philosophy to carry out Finite Element Analysis.  
Interpretation of results will be left to the reader.
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Study Cases
After Esha learnt how to perform FEA using Open Source Software like Salome-Meca and Code_Aster, she started 
her professional career in the same firm that she did her internship.  She was happy that John was her mentor all 
the way long.  Esha started gaining more experience with Linear Static Finite Element Analysis, and with more 
experience she needed less reliance on John’s guidance.  Esha started doing her FE Analysis with more confidence.

After several months, John caught up with Esha to find out how she was feeling regarding the use of Open Source 
Software for Finite Element Analysis.  Esha was very excited to tell John all about her experiences while they met 
for coffee.  Then Esha told John that every now and then a different type of FE Analysis comes to her for which she 
is not ready yet.  She has to pass them to her other colleagues as she is not feeling confident and she is feeling a bit 
lost.  As usual John was listening to her words carefully and asked her if he could help.  Esha was waiting for John 
to say that and she listed the analysis which she felt were a bit tough for her to do.

Parametric Modelling in Salome for Geometry and Mesh generation

Esha said that John had taught her how to “Dump the study” so that if she wants to recreate the geometry and 
mesh, it becomes easy for her.  But what if she wants to change some of the parameters.  What if Esha wants to 
generate geometry of the Pressure Vessel and Nozzle junction with different PV Diameter and Nozzle Diameter?  
What if she wants to change the mesh density in the PV Shell thickness or in the Nozzle thickness?

Combining element types in a single FE Analysis

Esha said that sometimes the models are too big and it would really help her if she could combine 3D elements 
with shell elements and Beam elements.  This would make FE Analysis run faster without compromising her 
results.  Was there a way to do this in Salome and Code_Aster?

Non Linear Material Analysis

Esha said that what John taught her in last book in Chapter 9 for checking against Allowable stress of the material 
was sufficient at that time, but she wanted to know if she could put the Graph of the Material Properties in Salome 
or Code-Aster and if the Analysis could take care of checking when the Allowable stress has been reached and stop 
the analysis?

Contact FE analysis

Esha said that she was happy to perform Assembly FE Analysis, but sometimes there is a requirement where she 
needs a gap between two parts and that load can only be translated once there is contact between surfaces.  Was 
there a way to do it in Code_Aster?

Modal Analysis

Sometimes in her career, Esha had come across a FE problem where she needed to find the Natural frequencies of 
a given shape of the object.  Esha asked John, if it was possible in Code Aster to find out the Natural frequencies of 
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the object by performing Modal Analysis?

Thermal Analysis

Esha remembered that once she was asked if there was a way to perform Thermal analysis in Code_Aster.  As 
Esha didn’t know, she had to again pass it along to her colleague.  Is there a way to conduct Thermal Analysis in 
Code_Aster?

These were some of the example problems that she had the opportunity to do but was not able to do them due to 
her limited knowledge.  There were some more problems that she wanted to discuss with John but first she wanted 
to know if her existing problems can be solved.

John told Esha that both Salome and Code_Aster were capable of conducting the analysis she asked for and much 
more.
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Chapter 1 - Case12
Parametric Modelling of a Pressure Vessel 
Geometry
John was glad that Esha asked for help when she needed.  
John said that first he will show Esha, how to perform a 
Parametric Modelling of the same Pressure Vessel Geometry 
that they created in Chapter 9 / Case 9 of previous book.  This 
time Esha was the client as she had a specific request and John 
was the Engineer.
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Step 1: Description of the problem

John asked Esha, what the exact outcome that Esha was looking for was.  Esha said that in previous book in Chapter 
9 John had showed her how to save a Python file from which she could generate the geometry again and again.  But 
editing that file was time consuming and sometimes she made a mistake in entering the data and was confused in 
looking through series of lines of Python in the “.py” file.  She wanted to know if there was an easy way in which 
she could just enter the values of the Parameters and Salome could do the modelling and meshing by itself.

John said that Salome indeed was very powerful and the request that Esha made was easily achievable in Salome. 
John told Esha that there are two methods in which the request that Esha has made can be accomplished.  One 
method is to edit the “.py” file manually, enter additional parameters and use them in the file to generate geometry 
and mesh it.  The second method was to use something called “Notebook” in Salome that stores parameters and 
which can be edited.  John will show Esha both of this methods.

Step 2: Input values for the FE analysis

Dimensions of the Pressure Vessel are similar to the previous book Chapter 9.

ID of Cylindrical shell of PV: 2000mm (2m)

Thickness of Cylindrical shell of PV: 10mm (0.01m)

Half Length of Cylindrical shell of PV: 1500mm (1.5m)

Dimensions of the Nozzle are

ID of the Nozzle: 300mm (0.3m)

Thickness of the Nozzle: 10mm (0.01m)

Projection of Nozzle: 300mm (0.3m)

Step 3: Parametric Modelling by direct editing of .py file

John copied Python file “Case9.py” from Case9 folder and saved it as “Case12.py” in a separate folder named 
Case12.

Then John double clicked the file to open it.  He told Esha that each and every line in this file is either a code that 
tells Salome about the geometry and mesh or is a comment.  Then he scrolled down the file till he could see the 
following code.

# -*- coding: iso-8859-1 -*-

###

### This file is generated automatically by SALOME v6.3.0 with dump python functionality

###
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Just below the above statements we will write our code for making this file do parametric modelling.  This code 
can be written anywhere in the file, but as these lines of code are for initialising variables that store 
information the will be used in modelling they should be initialised before the values are used. 

Python code is really easy and if you have done programming with any other language, you will feel Python to be 
a fun and easy language.

Things to remember in Python language:

1.	 You don’t need to end the statement with a semi-colon “;”

2.	 Python ends the statement when “Enter” (Carriage Return / Line Feed) is encountered

3.	 If you are initialising a variable, Variable Name will be on the left side of the = sign and value will be on 
the right side

4.	 Mathematical operations have regular meaning and precedence

5.	 Everything after “#” will be considered as a comment

With this in mind let’s add variables that will hold information for Geometry and Mesh.

Add the following lines:

#########################

#Parameters for Geometry#

#########################

#Pressure Vessel Outside Radius

PV_OR = 1010

#Pressure Vessel Inside Radius

PV_IR = 1000

#Pressure Vessel Height

PV_Height = 1500

#Nozzle Outside Radius

Nozz_OR = 160

#Nozzle Inside Radius

Nozz_IR = 150

#Nozzle Protrusion Length

Nozz_Protrusion = 200

#Height of Cylinder for Nozzle Construction

Nozz_Len = PV_OR + Nozz_Protrusion
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#####################

#Parameters for Mesh#

#####################

#Number of Segments for Global Meshing

GlobalSeg = 15

#Number of Segments for Pressure Vessel Shell Thickness Meshing

PVSeg = 5

#Number of Segments for Nozzle Shell Thickness Meshing

NozSeg = 5

###################

#End of Parameters#

###################

After adding the parameters that will be used in the creation of geometry and mesh, lets add these in the python 
file.

Find the lines shown below and enter the parameters defined earlier in their respective locations.  Parameters 
entered manually are shown with Red colour.

Cyl_PV_OD = geompy.MakeCylinderRH(PV_OR, PV_Height)

Cyl_PV_ID = geompy.MakeCylinderRH(PV_IR, PV_Height)

Cyl_Noz_OD = geompy.MakeCylinderRH(Nozz_OR, Nozz_Len)

Cyl_Noz_ID = geompy.MakeCylinderRH(Nozz_IR, Nozz_Len)

Vx = geompy.MakeVectorDXDYDZ(1, 0, 0)

Vy = geompy.MakeVectorDXDYDZ(0, 1, 0)

Vz = geompy.MakeVectorDXDYDZ(0, 0, 1)

geompy.Rotate(Cyl_Noz_OD, Vy, 90*math.pi/180.0)

geompy.Rotate(Cyl_Noz_ID, Vy, 90*math.pi/180.0)

geompy.TranslateDXDYDZ(Cyl_Noz_OD, 0, 0, PV_Height / 2)

geompy.TranslateDXDYDZ(Cyl_Noz_ID, 0, 0, PV_Height / 2)

Geom_OD = geompy.MakeFuse(Cyl_PV_OD, Cyl_Noz_OD)

Geom_ID = geompy.MakeFuse(Cyl_PV_ID, Cyl_Noz_ID)

PV_Whole = geompy.MakeCut(Geom_OD, Geom_ID)

#Please note that § is entered here for clarity purpose

# to show that line continues below without any break
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# Please do NOT enter § sign in your code.

a3D_Sketcher_1 = geompy.Make3DSketcher([0, 0, 0, PV_OR, PV_OR, 0, § 

PV_OR, PV_OR,PV_Height, 0, 0, PV_Height, 0, 0, 0])

Face_1 = geompy.MakeFaceWires([a3D_Sketcher_1], 1)

Revolution_1 = geompy.MakeRevolution(Face_1, Vz, 270*math.pi/180.0)

PV = geompy.MakeCut(PV_Whole, Revolution_1)

P0 = geompy.MakeVertex(0, 0, PV_Height / 2)

Plane_Vy = geompy.MakePlane(P0, Vy, PV_OR * 5)

Plane_Vz = geompy.MakePlane(P0, Vz, PV_OR * 5)

PV_1 = geompy.MakePartition([PV], [Plane_Vy, Plane_Vz], [], [], §

geompy.ShapeType[“SOLID”], 0, [], 0)

P1 = geompy.MakeVertex(0, 0, 0)

P2 = geompy.MakeVertex(0, (PV_OR * math.sin(45*math.pi/180.0) + §

Nozz_OR) / 2, PV_Height / 2)

P3 = geompy.MakeVertex(0, 0, PV_Height)

By doing above changes we have made geometry creation parametric.

Now to make meshing parametric, find the lines shown below and then we need to make following changes

Global_Mesh_Seg = Regular_1D.NumberOfSegments(GlobalSeg)

Global_Mesh_Seg.SetDistrType( 0 )

Quadrangle_2D = PV_Mesh.Quadrangle()

Hexa_3D = smesh.CreateHypothesis(‘Hexa_3D’)

status = PV_Mesh.AddHypothesis(Hexa_3D)

Regular_1D_1 = PV_Mesh.Segment(geom=PV_SubMsh)

PV_Thk_Seg = Regular_1D_1.NumberOfSegments(PVSeg)

PV_Thk_Seg.SetDistrType( 0 )

Propagation_of_1D_Hyp_on_opposite_edges_1 =                    §

Regular_1D_1.Propagation()

Regular_1D_2 = PV_Mesh.Segment(geom=Noz_SubMsh)

Noz_Thk_Seg = Regular_1D_2.NumberOfSegments(NozSeg)

By doing above changes we have made the meshing as parametric too.
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Now Start Salome Meca and Click File -> Load Script, then select the python file we saved earlier, after some 
time mesh of the Pressure vessel with the dimensions you entered in parameters will be displayed.

Just to check if the python file and parameters are working properly, John entered following parameters 
(Changes marked in Red)

#########################

#Parameters for Geometry#

#########################

#Pressure Vessel Outside Radius

PV_OR = 1050

#Pressure Vessel Inside Radius

PV_IR = 1000

#Pressure Vessel Height

PV_Height = 1500

#Nozzle Outside Radius

Nozz_OR = 300

#Nozzle Inside Radius

Nozz_IR = 290

#Nozzle Protrusion Length

Nozz_Protrusion = 200

#Height of Cylinder for Nozzle Construction

Nozz_Len = PV_OR + Nozz_Protrusion

#####################

#Parameters for Mesh#

#####################

#Number of Segments for Global Meshing

GlobalSeg = 15

#Number of Segments for Pressure Vessel Shell Thickness Meshing

PVSeg = 5

#Number of Segments for Nozzle Shell Thickness Meshing

NozSeg = 5

#End of Parameters#

###################
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And he got following as a result

As can be seen, the thickness of Pressure vessel has increased and the Nozzle diameter has also increased.
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Step 3 again: Parametric Modelling by using Notebook

John told Esha that Salome provides a feature called Notebook which is very powerful and that is what we are 
going to use next.

# Description Figure

1

Modelling steps shown here are exactly same as shown in previous book in Chapter 9, with the only 
difference of using Notebook to add parameters.  First we will add Parameters to the Notebook and 
then use those while generating geometry and mesh.

Open Salome-Meca and start Geometry Module.

2

Click File -> Notebook and a 
window will popup as shown 
in adjacent figure.

This is Salome Notebook.  It 
is blank right now, but we will 
add Parameters1 soon.

3

Click below Variable Name and 
the field will be ready to accept 
Variable Name.

Enter “PV_OR” as the variable 
name, Press “Tab” and the focus 
will move to Variable Value, 
enter “1010” as the Variable 
Value.

PV_OR is Outside Radius of 
Pressure Vessel with a value of 
1010mm.
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# Description Figure

4

Enter other parameters as 
shown in adjacent figure.

One thing to note here is the 
“Nozz_Len” which is given a 
Variable Value as addition of a 
two Variables.2

5
We are done adding Geometric Parameters.  Click “Apply and Close”

Next we will start generating our geometry.
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# Description Figure

6

Click New Entity -> Primitives 
-> Cylinder.

Select the second Option for 
cylinder, give it a Name “Cyl_
PV_OD” and enter “PV_OR” 
for Radius and “PV_Height” 
for Height.

Click “Apply”

For second Cylinder, use “Cyl_
PV_ID” as Name and enter 
“PV_IR” for Radius and “PV_
Height” for Height.

Click “Apply”

Use “Cyl_Noz_OD” as Name 
and enter “Nozz_OR” for 
Radius and “Nozz_Len” for 
Height.

Click “Apply”

Use “Cyl_Noz_ID” as Name 
and enter “Nozz_IR” for Radius 
and “Nozz_Len” for Height.

Click “Apply and Close”

7

As can be seen from the Cylinders that have been created, we need to Translate and Rotate the 
cylinders created for Nozzle and place them in their proper location and orientation.

For that we need to create Vectors in all three directions.  Then use Vector in Y direction to rotate 
the cylinders for nozzle and then translate them.
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# Description Figure

8

Click New Entity -> Basic -> 
Vector.

Select the Second Option for 
Vector, Give it a name “Vx” 
(Vector in X direction) and 
enter 1, 0, 0 for X, Y and Z.

Click “Apply”

Next give the name “Vy” and 
enter 0, 1, 0 for X, Y and Z.

Click “Apply”

Next give the name “Vz” and 
enter 0, 0, 1 for X, Y and Z.

Click “Apply and Close”

9

Click Operations -> 
Transformation -> Rotation.

Select “Cyl_Noz_OD” as 
Objects, “Vy” as Axis, enter 
“90” as Angle and Untick 
“Create a copy” as we do not 
want to create a new cylinder.

Click “Apply”

In the similar manner, Rotate 
“Cyl_Noz_ID” as shown above 
as well.

Click “Apply and Close”
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10
Next to transform the Cylinders we need Half height of the Pressure Vessel, As we did not create 
it earlier, we need to create it now.  Note that Salome does not allow Arithmetic operations in the 
field where you need to enter Values.  You can only perform arithmetic operations in Notebook.

11

Click File -> Notebook and add 
“PV_Half_Height” as a new 
Variable as shown in adjacent 
figure.

Click “Apply and Close”.

As you can see, if you forgot to 
add a Variable at the start of the 
geometry creation, you can do 
that at a later stage.
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12

Click Operations -> 
Transformation -> Translation.

Select “Cyl_Noz_OD” as 
Objects, and enter “PV_Half_
Height” for Dz, Untick “Create 
a copy” as we do not want a new 
copy of translated cylinder.

Click “Apply”.

Translate “Cyl_Noz_ID” as 
shown above as well.

Click “Apply and Close”. 

13

Now we need to fuse the Pressure Vessel and Nozzle OD Cylinders to generate a Geometry for the 
OD and then we need to fuse ID Cylinders to generate a Geometry for ID.

After that we need to Remove the ID geometry from OD geometry to generate a Geometry that 
will be our Pressure Vessel.
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14

Click Operations -> Boolean 
-> Fuse.

Give it a Name “Geom_OD” 
and select “Cyl_PV_OD” as 
Object 1 and “Cyl_Noz_OD” 
as Object 2.

Click “Apply”

Enter a new Name “Geom_ID” 
and select “Cyl_PV_ID” as 
Object 1 and “Cyl_Noz_ID” as 
Object 2.

Click “Apply and Close”

15

Click Operations -> Boolean 
-> Cut.

Give it a Name “PV_Whole” 
and select “Geom_OD” as 
Main Object and “Geom_ID” 
as Tool Object.

Click “Apply and Close”
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16

Right Click “PV_Whole” in 
Object Browser and Select 
Show Only.  Change the mode 
to “Shading”.

You should be able to see 
something similar to adjacent 
figure.

Rotate it, zoom it and see the 
Pressure Vessel shell that you 
have created.

Next we will remove excess 
geometry as we only need 90 
degrees of this whole PV.
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17

Click New Entity -> 3D Sketch.

In the window that opens, keep 
default name and “Absolute” 
Coordinates Type.

Enter following Numbers for 
X, Y and Z respectively:

0, 0, 0 -> “Apply”

PV_OR, PV_OR, 0 -> “Apply”

PV_OR, PV_OR, PV_Height 
-> “Apply”

0, 0, PV_Height -> “Apply”

Next, Click “Sketch Closure”.

This will create a frame for the 
face we will create in next step.

18

Now we need to create a Face 
out of the 3D sketch we just 
created.

Click New Entity -> Build -> 
Face.

Keep default Name “Face_1”, 
select “3D Sketcher_1” as 
Objects and make sure that 
“Try to create a planar face” is 
ticked.

Click “Apply and Close”
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19

Now we will revolve this face to 
create the geometry.

Click New Entity -> Generation 
-> Revolution.

Keep default Name as 
“Revolution_1”, Select “Face_1” 
for Objects and “Vz” for Axis.  
Enter “270” for Angle, Untick 
“Both Directions”.

Click “Apply and Close”

20

Click Operations -> Boolean 
-> Cut.

Give it a Name “PV” and select 
“PV_Whole” as Main Object 
and “Revolution_1” as Tool 
Object.

Click “Apply and Close”
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21

Right Click “PV_Whole” in 
Object Browser and Select 
Show Only.  Change the mode 
to “Shading”.

You should be able to see 
something similar to adjacent 
figure.

22
We will need to partition this geometry such that each partitioned solid has only 6 edges.

We need to create two planes that will cut the Geometry in 4 equal pieces.  For this we will need to 
create two planes perpendicular to each other and that intersect at the centre of the nozzle.
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23

First we will create a point from 
which the plane will pass.

Click New Entity -> Basic -> 
Point.

Click on First constructor of 
Points, give it a Name “P0” and 
enter co-ordinates as shown in 
the adjacent figure.

Click “Apply and Close”

24

Now we need to create two 
Planes with sizes equal to 5 
times the Diameter of Pressure 
Vessel.  So we will go back to 
Notebook and add another 
Parameter “OR_x_5” as shown 
in adjacent figure
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25

Click New Entity -> Basic -> 
Plane.

In the window, Select first 
constructor for Plane, give it a 
Name “Plane_Vy”, Select “P0” 
as Point and “Vy” as Vector.  
Enter “OR_x_5” as the “Size of 
plane”.

Click “Apply”

For the second Plane, give it a 
Name “Plane_Vz”, Select “P0” 
as Point and “Vz” as Vector.  
Enter “OR_x_5” as the “Size of 
plane”.

Click “Apply and Close”

26

Now we partition the geometry.

Click Operations -> Partition.

Give it a Name “PV_1”, select 
“PV” as Objects and for the 
Tool Objects select both Planes 
“Plane_Vy” and “Plane_Vz” in 
the Object Browser by Clicking 
on them while pressing “Ctrl”.

Make sure Resulting Type is 
“Solid”.

Click “Apply and Close”
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27

We are not done yet, we still need to partition this geometry further such that each individual solids 
will have only 6 sides.

Next we will create a curve edge that will aid in generating a curved surface to partition the 
geometry further.

At this point in time, Notebook is not able to handle advanced python code like the one we added 
manually in “Case12.py”

(PV_OR * math.sin(45*math.pi/180.0) + Nozz_OR) / 2

 so we will just add a simple formula for Point P2 as PV_OR / 2.5

28
Add another variable named 
“Point_2_y” with the value as 
shown in adjacent figure
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29

Click New Entity -> Basic -> Point.

Click on First constructor of Points, give it a Name “P1” and enter co-ordinates as shown below.

For Point “P1” enter 0, 0, 0 for X, Y, Z -> Click “Apply”

For Point “P2” enter 0, Point_2_y, PV_Half_Height for X, Y, Z -> Click “Apply”

For Point “P3” enter 0, 0, PV_Height for X, Y, Z -> Click “Apply and Close”

30

Next we generate a Curve from 
these three points.

Click New Entity -> Basic -> 
Curve

Select third constructor for 
Interpolation, keep default 
Name of “Curve_1”, Creation 
Mode should be “By Selection”.

Now for Points we will directly 
select them from Object 
Browser by Clicking on them 
while holding “Ctrl” key.  The 
order in which you select 
the points is critical as the 
interpolation will occur based 
on that selection.

Select Point “P1” then “P2” and 
last “P3”.

Click “Apply and Close”
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31

We will extrude this “Curve_1” 
to generate our curved plane.

Click New Entity -> Generation 
-> Extrusion.

Select first constructor for 
Extrusion, keep default 
Name of “Extrusion_1”, select 
“Curve_1” as Base and “Vx” as 
Vector, enter “Nozz_Len” for 
Height.

Click “Apply and Close”
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32

Now we will mirror this 
Extrusion to form our second 
Tool object for Partition.

Click Operations -> 
Transformation -> Mirror 
Image.

Select third constructor 
for Mirror, keep default 
Name of “Mirror_1”, select 
“Extrusion_1” for Objects and 
“Plane_Vy” for Plane Mirror.

Make sure “Create a copy” is 
ticked as we want a copy of the 
existing extrusion.

Click “Apply and Close”
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33

Now we partition the geometry.

Click Operations -> Partition.

Give it a Name “PV_2”, select 
“PV_1” as Objects and for 
the Tool Objects select Planes 
“Extrusion_1” and “Mirror_1”.

Make sure Resulting Type is 
“Solid”.

Click “Apply and Close”

34

We still need more partitions 
to make sure that every face 
has 4 edges and every solid has 
6 faces.

Right Click Cylinder “Cyl_PV_
OD” and Select “Show Only”

Click New Entity -> Group -> 
Create.

Select third constructor for 
Shape Type, change the Name 
to “PV_OD”, the Main Shape 
should be “Cyl_PV_OD” and 
select the Cylindrical Surface 
and Click “Add”

Click “Apply and Close”

Next do the same for Cylinder 
“Cyl_Noz_OD” and give it a 
name “Noz_OD”.
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35

Now we partition the geometry 
one last time.

Click Operations -> Partition.

Give it a Name “PV_Final”, 
select “PV_2” as Objects and 
for the Tool Objects select 
Planes “PV_OD” and “Noz_
OD”.

Make sure Resulting Type is 
“Solid”.

Click “Apply and Close”.

Right Click “PV_Final” and 
Select “Show Only” and you 
should be able to see something 
similar to the adjacent figure.

36

Now that the Geometry modelling is complete, we need to create Groups of Faces where we will 
apply Boundary Condition and Loads.

Boundary Conditions will remain same as Previous Study we did for Pressure Vessel Shell for most 
of the part.
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37

Click New Entity -> Create -> 
Group, Select the Third button 
to Add Face.

Give Name “Dz0” to the bottom 
face of the shell, “LongPres” to 
the top face and “Norma” to the 
two vertical faces.

Give Name “Press” to the Inside 
Face of the Pressure Vessel 
Shell and also to the Inside face 
of Nozzle.

38

We will need a Face Group on 
the Nozzle to apply Force.

Give it a Name “Force” and 
select 4 faces as highlighted in 
Red in adjacent figure.  Click 
“Add” to add them and then 
Click “Apply”
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39

Now we need to create Edge 
Group for Sub Meshes that we 
will create in the thickness of 
the Pressure Vessel and Nozzle.

In the Create Group Window, 
Select the Second button to 
Add Edge.

Add all four edges that we had 
selected in previous chapter 
for the PV Shell and additional 
edges that are created due to 
partitioning of the PV in the 
middle of the Length.

40

Also Add four edges as shown 
in the adjacent figure which are 
on the Inside of Nozzle and on 
PV Shell, and give it a Name 
“PV_SubMsh”.

“PV_SubMsh” should have 12 
edges in it.
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41

Similarly we will create Edge 
group for “Noz_SubMsh” as 
shown in adjacent figure.

There will be 8 edges in “Noz_
SubMsh”

42
This concludes creating Geometry.

Save this file.
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1

We spend quiet a long time Modelling the Pressure vessel and Nozzle junction but it is well worth.

Due to the effort spent earlier, we will have to do less effort in Meshing the geometry.

Select Mesh module in Salome-Meca.

2

Click on Mesh -> Create Mesh

Change the Name to “PV_
Mesh”.

Click on the Button “Assign a set 
of hypotheses” and Select “3D: 
Automatic Hexahedralization”
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3

Now in the next window it 
asks for Number of Segments 
for Global Mesh.  We need 
to define Parameters for the 
Mesh Number of Segments in 
Notebook.

We will define:

GlobalSeg with Value 15

PVSeg with Value 5

NozSeg with Value 5

4

In the window that pops 
up, change the Name to 
“Global Mesh Seg” and enter 
“GlobalSeg” as Number of 
Segments.

Click “OK”

Click “Apply and Close”
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5

Right Click “PV_Mesh” and 
Select “Create Sub-Mesh”.

Change the Name to “PV_
Sub”, select “PV_SubMsh” for 
Geometry.

Select “Wire discretisation” for 
Algorithm.

Click on the Gear button next 
to Hypothesis and Select “Nb. 
Segments”

6

In the window that pops up 
change the Name to “PV Thk 
Seg” and Number of Segments 
to “PVSeg”.

Click “OK”

7

Back to Create sub-mesh 
window.

Click on the Gear button next 
to “Add. Hypothesis” and Select 
“Propagation of 1D Hyp. On 
opposite edges”.

This will ensure that the sub 
mesh is propagated throughout 
the thickness.

Click “Apply and Close”
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8

Do the same with “Noz_
SubMsh” and for the Number 
of Segments use “NozSeg”.

Make sure that “Propagation 
of 1D Hyp. On opposite edges” 
has been selected.

Click on “Apply and Close”

9

Right Click on “PV_Mesh” and 
Select “Compute”.

As can be seen the total number 
of Edges, Faces and Volumes 
has been reduced.

Number of Volumes reduced 
from 54000 to 15000.

This will reduce the time taken 
by Code_Aster to carry out FE 
Analysis.
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10

We need to create Mesh Groups 
from Geometry Group.

Right Click “PV_Mesh” and 
Select “Create Groups from 
Geometry”.

Click on the Curved Arrow 
next to Geometry and Select 
“Press” from Object Browser. 
Click “Apply”

Do the same with “Dz0”, 
“LongPres”, “Norma” and 
“Force”

11
This concludes generation of Mesh.

Save this study.

Change Parameter in Notebook

Now is the real test of Notebook.  Once geometry and mesh is generated and the file has been saved, Click on 
File -> Notebook and change the parameters and see if the study updates.

For example, change the value of PV_IR from 1000 to 750 and Click “Update Study”. Salome will be performing 
the steps that we carried out to generate geometry and mesh again and when done, it will present the final result.  
Our result is shown below.
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John told Esha that using Notebook is very easy and updating geometry and mesh is done by just a click of a 
button, but as we noticed, Notebook is not powerful yet and complex formulas cannot be entered.  If you want to 
enter complex formulas, you better edit the python file manually.
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Summary

John asked Esha to summarise what she learnt by doing this Parametric Modelling.  Esha summarised it as below

▶▶ How to edit a Python file.

▶▶ How to enter Parameters in Python file.

▶▶ How to Use Parameters in Geometry and Mesh creation.

▶▶ How to use Notebook in Salome.

▶▶ How to add Parameters and its Value in the Notebook.

▶▶ What are the limitations of Notebook.

▶▶ How to update study by changing Parameters in the Notebook.

Endnotes

1	  Parameters are called Variables

2	  You can perform arithmetic calculations in Variable Value field.
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What will be covered in Volume 3
Learning new topics from John, Esha was equipped with new enthusiasm.  She started working again and the 
projects that formerly she had to forward to her colleagues due to lack of understanding, she could do them with 
ease.

Nearly after a year, John caught up with Esha to find out how she was feeling regarding the use of new and a bit 
more advanced use of Open Source Software for Finite Element Analysis.  Esha, now a seasoned engineer, told 
John that she was very happy to get new information for the help that he had provided her as it helped her in her 
job.  She could do the projects with ease and now was also able to teach others the use of Open Source Software.

Then Esha told John that every now and then an advanced type of FE Analysis comes to her for which she is not 
ready yet.  She has to pass them to her other colleagues as she is not feeling confident and she is feeling a bit lost.  
As usual John was listening to her words carefully and asked her if he could help.  Esha was waiting for John to say 
that and she listed the analysis which she felt were a bit tough for her to do.

Using Python for Parametric Modelling and FE Analysis

Esha said that using Python for Parametric modelling was good, but every now and then when she has to re-run 
the study, with more refined mesh, she had to re-do all the steps again.  She wanted to know if using Python, can 
she automate the phase of Modelling, Meshing and running the analysis.

Using Hommard for adaptive meshing

Esha had heard about Hommard and that it can be used for adaptive meshing.  She wanted to learn how to use it.

Advanced Thermal FE Analysis

After learning about two types of Thermal FE Analysis, conduction and convection, Esha wanted more.  She asked 
John if he could teach her advanced Thermal Analysis.  She wanted to learn Thermal Radiation, Thermal Analysis 
of an Assembly and so on.

Thermo-Mechanical FE Analysis

Finding out the temperature of different parts in Thermal analysis is good, but there was something missing.  Esha 
wanted to learn, how to find out thermal deformation in a part or assembly.  She wanted to know if the thermal 
Stress Strain curve of the material can be attached to thermal and mechanical analysis.

Pipe Stress Analysis

Esha knew that standard Pipe Stress Analysis programs available in the market use Beam model for Stress analysis.  
She wanted to learn how to perform Pipe Stress Analysis using Salome-Meca and Code_Aster.
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Fluid Structure Integration

Esha remembered that doing Computational Fluid Dynamics, you can find out the pressure on the boundary 
walls, she wanted to know if there was a way to project these on to the mechanical parts and carry out FE analysis.  
In short she wanted to learn Fluid Structure Integration of FE Analysis.

After listing the above analysis, Esha looked at John who was smiling and had a sparkle in his eyes.  John was ready 
to teach Advanced FE Analysis to Esha.

John told Esha that both Salome and Code_Aster were capable of conducting the analysis she asked for and much 
more.
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Appendix A

Other sources of information

This section is provided here for motivated users who are hungry for more information on the software covered 
in this book.  Links are provided to the Software home page and also to the User Forums.  Links provided to the 
websites are correct at the time of writing this; if by any chance these links don’t work, just use any search engine 
to find relevant software.

1.	 Salome website http://www.salome-platform.org/

2.	 Code Aster website http://www.code-aster.org/V2/spip.php?rubrique2

3.	 CAELinux website http://www.caelinux.com/CMS/

4.	 Efficient website http://engineering.moonish.biz/efficient/

5.	 Salome forum http://www.salome-platform.org/forum

6.	 Code_Aster forum http://www.code-aster.org/forum2/

7.	 CAELinux wiki http://www.caelinux.org/wiki/index.php/Main_Page

http://www.salome-platform.org/
http://www.code-aster.org/V2/spip.php?rubrique2
http://www.caelinux.com/CMS/
http://engineering.moonish.biz/efficient/
http://www.salome-platform.org/forum
http://www.code-aster.org/forum2/
http://www.caelinux.org/wiki/index.php/Main_Page
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Appendix B

Installing Software required for this book

All case studies mentioned in this book can be performed on a computer that has Ubuntu 12.04 Operating 
System and which has Salome-Meca and Efficient installed on it.

Ubuntu 12.04 Configuration

Ubuntu 12.04 can be installed on a computer alongside Windows 7 or it can be installed as a Virtual Operating 
System.  Decision of how to install Ubuntu is left to the readers.

I have installed Ubuntu 12.04 in a virtual environment using Virtual Box.

Configuration of Ubuntu on Virtual Box is shown below
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Salome-Meca 2013.2 installation

Download Salome-Meca 2013.2 from their website

http://www.code-aster.org/V2/spip.php?article303

It downloads as a rar file and it is in my Downloads folder as shown below.

http://www.code-aster.org/V2/spip.php?article303
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Now Open Terminal and go to Downloads Folder

Enter the command by typing in Terminal
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tar xvf SALOME-MECA-2013.2-LGPL.tgz &&./SALOME-MECA-2013.2-LGPL.run

Follow the prompt and install Salome-Meca 2013.2 in desired location.

Once Salome-Meca installation is complete, a desktop icon will be created which can be double clicked to start 
Salome-Meca 2013.2

Have fun.

If you have any trouble installing the software, consult Code_Aster Forums on

http://www.code-aster.org/forum2/viewforum.php?id=26

Efficient Install

Efficient is developed in Java and to run it in Ubuntu, you will need OpenJDK Java 7 runtime.

To download and install it go to

https://apps.ubuntu.com/cat/applications/precise/openjdk-7-jre/

Install it on your Ubuntu installation.

http://www.code-aster.org/forum2/viewforum.php?id=26
https://apps.ubuntu.com/cat/applications/precise/openjdk-7-jre/
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Download Efficient version 0.1.1 from http://engineering.moonish.biz/efficient/

On the right hand side latest Efficient version can be downloaded.  Click on “Download v0.1.1” and a Java Jar file 
named “Efficient_v0-1-1.jar” will be downloaded on your computer.  Copy it to a proper location.

To run Efficient, Right Click on “Efficient_v0-1-1.jar” and Select “Open With OpenJDK Java 7 Runtime”

http://engineering.moonish.biz/efficient/
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